Multithreading.. off?

General OpenMP discussion

Multithreading.. off?

Postby krotton » Sat Aug 23, 2008 1:28 pm

I am now working on a multithreaded server application using OpenMP. I use some `parallel pragmas` inside it, it compiles with no trouble and then.. I have no parallelity support. The funny thing is that the same code (downloaded via SVN) works perfectly at my friend's. We are both using GCC (with libgomp enabled).

I've tried to run any of the simplest OpenMP examples - all of them stated, that omp_get_thread_num() was always returning 0 and omp_get_num_threads(): 1. I tried overriding with the `num_threads` clause and omp_set_num_threads() - no result.

My configuration:
AMD Turion 64 ML-37 (one-core)
Linux: tried in Debian and Arch
Compiler: GCC 4.3.1

Thank you in advance, Krotton.

Re: Multithreading.. off?

Postby mwolfe » Mon Aug 25, 2008 3:22 pm

Without more details, it's hard to debug your problem. You say the same program worked at your friend's, and that you are both using gcc. Is it the same version? Did you compile with the same command line? Since others have used gcc with OpenMP successfully, this is most likely pilot error.

Return to Using OpenMP

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests